C5Alive General Category > C5 Chatroom

Motor not working control box had new R1 & D1 fitted but relay not working

(1/5) > >>

Moved this here from another post where it was developing into it's own post. ( http://c5alive.co.uk/forum/index.php/topic,3643.15.html ) Thanks all that have helped so far, appreciated. If solved it might help others another day.

In summary I replaced FS2 fuse in control box that was blown as nothing working on a C5 I bought except lights indicators and horn. The motor is not working and I've tried directly connecting it up but nothing although when I first tried this earlier last week I got a couple sparks and a twitch but no real motion. I'm having difficulty checking brushes as suggested so will dismantle in the week and clean it and have a look, assume that is an okay job.

Pod was not illuminating but the battery low buzzer went off after a few mins of connection. So with a little help reading posts and bending the ear of C5Mick who was on FB and been very helpful I've replaced R1 and D1 on the control board. The pod now illuminates (yay!) but the battery low buzzer still goes off after few minutes and the battery led's extinguish one by one before that happens. The relay for the motor isn't activating which means it certainly wont go even if the motor gets sorted.

There is 12v at X12 when button pressed, relay works in isolation, X1 to X13 no continuity X1 to shunt has continuity, no voltage at R10 is detected (c5mick says it should be 3.7v, thanks Mick) I tried the pod on my working C5 and it seems to work okay. So something is preventing the relay from activating. I'm sure it clicked when I replaced the fuse but I have had the board out and replaced the two items mentioned so it's been disturbed as it were. TR3 has been suggested as possible failure so could get one to replace that though i'm told its a tricky one to do and to be careful with the heat, hoping to test that tomorrow if it's possible to do.


Hi Mark - take a look inside the pod - check the condition of the soldered joints on the connector also the condition of R21 which is often burnt out - once the motor is up and running let us know what the pod lights do when the button is pressed.Also worth giving the red harness a wiggle in the control box as it may have a loose connection which would explain why the relay has stopped clicking - Regards Marty

Hi Mark,

the CB is the labourer and the pod is the brain of the C5. The CB will only work if all the parameters from the CB are correct and the pod gives the OK signal. You mention that after changing the fuse the motor kicked in shortly, this indicates that TR3 is OK. The voltage that C5mick mentioned originates from the ULA in the pod and activates TR3, and this signal will only be given if all the other parameters are correct.

From your description four things are suspect.

1) The condition of your battery.
2) The op-amp. This measures the battery level and current being consumed. If these are not correct you get no start signal.
3) The ULA. It may be on the way out.
4) The harness between the CB and the pod.

Firstly I would remove the pod, knock it left then right towards you, you may have to use a lot of force, until it pops out. Remove the harness and check that the pins are straight and are not corroded, if all is OK replace the harness, but leave the pod out for the moment.

Now if the op-amp is playing up then you would receive the symptoms that you now have, so I would recommend you replace the op-amp to begin with.
I would also recommend that you fit an IC socket so long as the op-amp is removed, this way you can swop the IC in the future without having to unsolder the connections. Both the IC (a 358) and the socket are cheap, so you don't have to worry about having deep pockets and short arms. ;D ;D

Before removing the IC make a note of the IC's location to ensure correct replacement. If possible try and cut the leads from the IC and remove the body, then you can remove the leads one by one and you need far less heat. If you are unable to cut the leads place a very small screwdriver under the IC to act as a lever, apply a little solder to your soldering iron and heat up the pads, and at the same time apply light pressure to the screwdriver. What ever happens don't apply too much heat or the pads will lift of the board, remove the IC step for step.

It would also be a good idea to mod the supply voltage to the IC as long as the board is out of the CB. As it stands it has a 12v supply, the problem is the 12v supply often has high voltage spikes that can destroy the the IC. This mod is recommended by the guys who designed the board.

I hope C5Mick also informed you not to seat D1 and R1 directly onto the board, but to leave a small air space to prevent burning the board.

One last point, to check continuity between X1 and X13 connect the multimeter and if you have no reading then swop the probes, as there is a diode in the circuit. This is to test the thermal cutout, but it much easier to remove the orange/orange connector from X6 and test the unit from the lead end of the connector. The whole thing is unnecessary as your motor kicked in at one point so the cutout is OK.

I'll post the IC voltage supply mod as soon as I find it.

Sow av phun.


Hi Mark,

here is the op-amp mod.


Guy's for very little money you can buy a solder extractor which you hold over your soldering iron and it 'sucks out' the solder - I will post a link when I have chance - I also recommend a temp controlled soldering iron which will limit board damage



[0] Message Index

[#] Next page

Go to full version