News:

Meeting the Gadget Show team
http://c5alive.co.uk/forum/index.php?topic=404.0


Author Topic: seen at Ackworth Steam and Vintage vehicle rally( Yorkshire)  (Read 2004 times)

0 Members and 1 Guest are viewing this topic.

Offline coverman

  • Sr. Member
  • ***
  • Posts: 487
  • Battery level: 4
Saw a C5 with mirrors but no battery or battery leads but with pod, motor, and control box installed in the motorcycle section.Went back a few times to find the owner but didn't succeed in locating him(her?)

Offline PLOD11

  • Millennium Member
  • *****
  • Posts: 1010
  • Battery level: 11
  • Trust No one !
Re: seen at Ackworth Steam and Vintage vehicle rally( Yorkshire)
« Reply #1 on: 19, July, 2010 - 11:09:19 »
Any pics ?

Offline coverman

  • Sr. Member
  • ***
  • Posts: 487
  • Battery level: 4
Re: seen at Ackworth Steam and Vintage vehicle rally( Yorkshire)
« Reply #2 on: 19, July, 2010 - 11:57:06 »
Didn't take a photo as it just looked like any other C5 except that it was misssing both battery and battery leads.

chrisbaildon

  • Guest
Re: seen at Ackworth Steam and Vintage vehicle rally( Yorkshire)
« Reply #3 on: 19, July, 2010 - 20:35:04 »
I have been working on my C5 this evening down at my fathers as he has a nice big double garage and he has just got back from Ackworth, he mentioned seeing the C5 and said it was none working.

My dad builds miniature traction engines, proper ride on ones & coal fired so we end going to most of the steam rallies in the North of England.

I am working on my C5 trying to get it ready to take to the Pickering steam rally at the beginning of August if anyone up North is going. It will be on display in the cycles section and I usually take it on the road run (about 2 mile trip on the Saturday evening), that is if I get it running again OK.