News:

C5 Alive attending the following event
Easter Sunday 20th April 2014 - Sandwich Gears of Change Motor Show - Kent
http://classicmusicandmotors.co.uk/flv_portfolio/motor-shows/


Author Topic: Electrical Problems !  (Read 1290 times)

0 Members and 1 Guest are viewing this topic.

Offline radiomarty

  • Administrator
  • Millennium Member
  • *****
  • Posts: 2641
  • Battery level: 100
Electrical Problems !
« on: 20, March, 2011 - 22:04:32 »
Hi all with the weather changing and having a C5 come in for restoration I ventured into the workshop to have a first look at the job....................

On powering up the Pod was flashing on both displays and beeping and changing light patterns a very unusual one. I replaced the pod and found the same problems so ventured into the control box for a closer look. Its always fun working out what people have been up to on this occasion the control box had obviously failed and somebody had basically wired the switch direct to the relay and left the pod to sing and dance !!!
I removed the mods to see what condition the control box was in - the standard burn out of D1 and the opp amp had blown so replaced those -The produced a slightly better condition but still the pod was not behaving as expected - upon changing the harness from pod to control box the pod now prevent a good condition - Time to try the motor  - pressed the switch and nothing but first green illuminated as expected - Check the motor direct of the battery and all ok - quick check of the circuit diagram and narrowed it down to a couple of resistors and the ztx 449 . Resistors checked out ok so replaced the transistor. Pressed the switch and nothing  - convinced this was going to fix it about an hour passed with lots of head scratching then it jumped out at me - the replacement ztx 449 had a stray BC212 in the packet !!!!! - Put the correct one in and eureka of she went !!!! Now all is working time to strip it down and start the restoration  :) :) :)

Offline PLOD11

  • Millennium Member
  • *****
  • Posts: 1010
  • Battery level: 11
  • Trust No one !
Re: Electrical Problems !
« Reply #1 on: 21, March, 2011 - 00:52:45 »
Well done,  ;D another C5 about to be put back on the road working as it should.

I think the restoration is the best bit about these for me,   ;)  getting them working correctly. Only problem is i cant bear to part with them once i have put all that hard work in.  :'(  :'(  :'(  :'( 

Karl

  • Guest
Re: Electrical Problems !
« Reply #2 on: 21, March, 2011 - 08:04:51 »
Well done,  ;D another C5 about to be put back on the road working as it should.

I think the restoration is the best bit about these for me,   ;)  getting them working correctly. Only problem is i cant bear to part with them once i have put all that hard work in.  :'(  :'(  :'(  :'( 

...I also enjoy the restoration side, but just don't seem to have enough spare time. Acquiring that batch from Rotterdam hasn't exactly eased the problem either  ;D

Good work on that control box marty, impressive stuff  8)

Offline Retro Andy

  • Global Moderator
  • Millennium Member
  • *****
  • Posts: 2097
  • Battery level: 12
Re: Electrical Problems !
« Reply #3 on: 21, March, 2011 - 17:50:32 »
I'm glad you don't live to far away for when mine goes wrong Marty  ;)

Retro Andy.